Please install all available updates for your release before upgrading. Can't upgrade to 20.10 from 20.04.1

In order, i’ve attempted:

  1. sudo apt-get update
  2. sudo apt-get upgrade
  3. sudo apt-get dist-upgrade
  4. sudo do-release-upgrade

After running the last step, it resulted in Please install all available updates for your release before upgrading. i also tried the above in order with just apt and not apt-get (per a prior post on askUbuntu)…i get the same message after getting to step 4. i tried running sudo apt autoremove after the upgrade step, but that didn’t do it. i tried removing packages that weren’t able to be upgraded after running step 2, but that didn’t do it (there was a dotnet-sdk that couldn’t be upgrade). notify is set to any new version of ubuntu. also tried running steps 1-3 then sudo update-manager, but i get the same message. my release from lsb_release -a is

  • Dist ID - Ubuntu
  • Desc - Ubuntu 20.04.1 LTS
  • Release - 20.04
  • Codename - focal

my 3rd party sources are:

EDIT:

disabling teamviewer and chrome in my 3rd party sources resolved the error.

Asked By: jellz77

||

disabling teamviewer and chrome in my 3rd party sources resolved the error. thank you guiverc for leading me in the right direction with my confusing post 🙂

Answered By: jellz77

sudo apt list –upgradable -a

This was my friend.

Answered By: user171959