Brother DCP-J152W – Scanner not working with Simple Scan

I have recently upgraded to Ubuntu 20.04 and the printer is working fine, but the scanner doesn’t work in document scan. I downloaded the scanner driver from the Brother site as advised, but still not working. Some suggestions would be much appreciated. Russell

Asked By: Russell

||

I had the same issue with another Brother I installed Gscan2pdf using Synaptic Package manager But I think it is in the snap store too Anyway it worked. That program can recognize my brother. It’s slow takes a bit so let it do it’s thing

Answered By: Vladimir Petrovich

I had similar problems with simplescan (aka Document scanner) after upgrading to 20.04. I also had Xsane installed, which DID work.I then installed Gscan2pdf as suggested by Vladimir Petrovich in this answer: https://askubuntu.com/a/1294468/225694 which also worked I had to monkey with the settings to get it to understand I was using US Letter size paper but in the end Gscan2pdf was far more intuitive to use than Xsane for multi-page scans

Answered By: Elder Geek
Categories: Answers Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.