Can't install Angry ipscan in ubuntu LTS 20.4

I can’t install Angry ipscan in ubuntu.When I tried to install it showed this:Error_Image

But I have already installed Oracle Java JDK. Screenshot:Java_image

I am not good with nmap or arp-scan & I have already used Angry Ipscan for about 2 years with GUI. So if you have any alternatives,please make sure that it has GUI or show me the process of installing my preferred package

thanks in advance…

Asked By: Rafi

||

The error you are getting is because you are not having the specific java. The solution is to install open-jdk-8 as it is a prerequisite. Therefore run the following commands to install it.

sudo apt update
sudo apt install openjdk-8-jdk
Answered By: Tejas Lotlikar

do this:

wget https://github.com/angryip/ipscan/releases/download/3.7.6/ipscan_3.7.6_all.deb
sudo apt install openjdk-8-jre gdebi
sudo gdebi ipscan_3.7.6_all.deb
Answered By: acgbox

Thanks. It worked for me after i followed below procedure. Problem with openjdk-8-jre upgrade and then followed the commands mentioned here.

Answered By: user642690
Categories: Answers Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.