Can't close Authentication Required window after login

I am using Ubuntu 20.04(Gnome3.36) and need help with this:

Screenshot

The Authentication Required window is stuck right after logging in and I can’t close it. I tried using xkill to close the window but it didn’t close, I think xkill doesn’t recognize the Authentication required window as a window.

I searched for answers but only found a reddit post which the author has the same problem, which is https://www.reddit.com/r/gnome/comments/fscvql/authentication_required_window/

Is there any easier ways to remove it than rebooting?

UPDATE 2022-12-27:

On Ubuntu 22.04 I don’t encounter this problem anymore, the issue seems to be fixed. But I also can’t restart the gnome shell as I am now using Wayland.

Asked By: MandiYang

||

I faced the same problem on Pop_!OS, no need to reboot actually;

The easier way is to just restart GNOME by one of two ways:

  • press Alt + F2, type r then Enter

or

  • in terminal, type killall -3 gnome-shell

This should just restart Gnome Shell. You will not lose your open windows, but you should be reminded to save all your work regularly!

Related bug: https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1824874

Answered By: Anan Raddad

Thank you for the nice tip!

For me it started happening seemingly all of a sudden. I am on a fresh Linux installation. Other than playing around with power management (suspend and hibernate) to make them work better, I did not fiddle around with anything else. It is happening after I login from suspension/reboot.

After a couple of days of trying to understand what might be wrong, I noticed a couple of things:

  • When trying to restart the window did not only display the 3 buttons Cancel, Restart, Power off BUT it stated that there is another user logged in (with the same name as me). I checked how many users were logged in but there was only one (me)
  • The authenticate window popup was popping up when I was trying to reboot (with the message ~= "authentication is needed for reboot")
  • All of a sudden the brightness control stopped working and my screen brightness was not changing when I was updating the slider (I know weird…but again I had done nothing to fiddle around with it)

Those clues led me to think that the latest package I had installed might be the culprit. It was the "chrome remote desktop" package which is related to logging the user to the current active window session and touching on display properties..

And after uninstalling the package everything worked as before! No stuck authentication popups, no duplicate ghost users and I can control my display’s brightness.

I hope those observations and my experience is useful to someone out there.

Answered By: Vasilis Prantzos

I solved same problem this way:

  1. I opened terminal: Ctrl + Alt + T,
  2. I found nautilus PID: ps ax | grep /usr/bin/nautilus
  3. I killed process by kill command: kill 1234

One-line command is: echo $( ps ax | grep /usr/bin/nautilus )

Answered By: Mikhail P

I don’t recommend the killall -3 gnome-shell approach because:

  • It causes Steam and any running games within to exit.
  • It has a weird side effect of bringing up new instances of GUI apps like 1Password rather than bringing up the existing minimized process.

I use the following alias ‘gf’ for "gnome fix":

For zsh and bash:

alias gf='dbus-send --type=method_call --dest=org.gnome.Shell /org/gnome/Shell org.gnome.Shell.Eval string:"global.reexec_self()"'

For fish:

alias gf 'dbus-send --type=method_call --dest=org.gnome.Shell /org/gnome/Shell org.gnome.Shell.Eval string:"global.reexec_self()"'
Answered By: Michael
Categories: Answers Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.