Help with BIOS/UEFI settings on Thinkpad T495

I had a dual boot installation of Ubuntu 19.04 and Windows 10 (from Lenovo itself) but Windows 10 had become extremely unstabe with BSoD’s every 10 minutes, even when I hadn’t even started using it. Anyway, while that happened, I would face another issue wherein I wouldn’t boot into grub at all, but get this screen: https://i.stack.imgur.com/BoIQf.jpg. This screen, but with options “ubuntu”, “Windows Boot Manager” and “PCI LAN”. Any of the options I chose led to the exact screen reappearing again and again and the only option was to reboot from the power button again and again until it booted into GRUB.

Now after resetting the Factory Keys, disabling and re-enabling Secure Boot from the BIOS settings and then finally also loading the default settings in the BIOS settings (I really went to town with those settings, I guess), I only get the “PCI LAN” option and nothing else at all. Maybe I messed the BIOS settings a bit much, but I cannot be sure. I tried running the Ubuntu installer but it detected no other drives but the USB flash drive I used as the Live Disk.

Keep in mind I cannot boot into the SSD at all, which, I suppose, I need to rectify, before doing anything else. I can share photos of the exact settings I have on if you want.

Asked By: hardbodybrain

||

You may check the following to ensure to be able to boot with your computer.

Check into your BIOS

  • From Startup tab > Boot, ensure you have HDD0 enabled on order 1.
  • From Security tab > Secure Boot, check Secure Boot is Disabled.

Check into your hard drive

If you are still unable to boot up, start from an Ubuntu USB boot disk, and from command prompt, run the following commands.

sudo fdisk -l

Now from your /dev/sdxx list, you should have one EFI system partition.

fdisk result

Mount this partition into a temporary folder

sudo mount /dev/sdxx /mnt

Now check the content, the minimum is having

./EFI/BOOT/grubx64.efi : this is grub efi boot file
./EFI/BOOT/BOOTX64.EFI : this is the windows boot file, but also the failsafe.

If those file are missing, you might be unable to boot your computer. You may reinstall it with.

grub-install /dev/sda

You can also read this complete guide to debug where your issue is.

https://wiki.debian.org/GrubEFIReinstall

Answered By: ob2

it is a bit late (roughly a year), but I "found" the solution to the problem I had. So what would happen to the SSD was that it would just not be detected. It was nothing wrong with the GRUB installation, it was safe. And I was able to just boot into it by just trying again and again to reboot.

I then got rid of Ubuntu eventually and just used Win10 for around six months, and it would crash if I’d move my laptop around but would run normally as long as it stayed in one place. The SSD not getting detected at boot problem would still happen however until it just stopped one day. A friend of mine said that the same thing happened to him once, and what he did was that he took out the M.2 SSD and cleaned off the contacts on it (carefully), and reinstalled it. For me, it didn’t take anything of that sort, which I feel lucky about, but it is a solution you may want to look into.

Sorry, nothing wrong with Ubuntu itself, and sorry for being so late to reply!

Another Edit (after nearly 3 more years): I also found the solution to the problem making my laptop crash upon movement. It made my laptop a desktop replacement for most of my ownership of it, but when I upgraded the RAM in it, I opened the shell and that just solved it. Never happened again, and I really tested it to make sure. Since then I have also swapped the SSD and even that’s worked well enough. So if someone gets this stupid and niche issue, don’t hesitate to open up your laptop and, I guess clean it, just as an excuse to make any issue that’s electrostatic (I guess) go away.

Since then, WSL has also come out and iterated on, and that has fulfilled most of my Linux needs as well, so that’s great too.

Answered By: hardbodybrain
Categories: Answers Tags: , , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.