Some applications on Ubuntu 19.10 very slow to start

My relatively fresh Ubuntu 19.10 on a top notebook is running flawlessly, but some applications are really slow to start. For now it’s keepassX, filezilla, deadbeef. Both takes about 30 seconds to show it’s window, but after that both are blazing fast as others.
May be someone can help me to find a solution?

Asked By: WhiteWind

||

After having the same problem and doing strace + a lot of reasearch I found out that this fixes the issue for good (filezilla, keepassX etc. all launch instantly now):

sudo apt-get install appmenu-gtk2-module

Then reboot.

Answered By: Stefan Iancu

Cannot confirm that installing appmenu-gtk2-module solves the problem. Also the “dbus-launch –exit-with-session” only provides a partial solution. For example VLC is facing the same startup issues. Starting it as “dbus-launch –exit-with-session vlc” avoids the described startup delay. However, integration into top panel and raven is lost in Budgie desktop.

Hence the question what exactly causes this problem and how to really solve it is still open.

Edit: I would like to clarify, what I consider being not OK with VLC when executed with dbus-launch. I attached four screenshots – two being suffixed with OK which show the integration into Budgie when being executed without dbus-launch. The second set – suffixed with NOK shows it being executed with dbus-launch. The difference is particularly noticeable in the vlcRaven screenshots. Furthermore the behavior when clicking the top panel icon is different. With dbus-launch left-clicking the icon reveals the shown menu, while the same hides/shows the application. The menu is opened upon right-clicking the icon. I do not consider the different behavior as showstopper for me though it might provide additional hints what’s actually causing the issue.

VLC Raven panel NOK
VLC Raven panel OK
Top panel NOK
Top panel OK

Answered By: Wolfgang

I can confirm the issue. For some application the launch is heavy delayed, other applications are starting pretty fast. After the launch every application is running normal without any further delays.

I am also able to confirm that I dont have any issues with starting applications if I’m using dbus-launch --exit-with-session vlc. Also running the application as root removes the delay.

strace is stopping at that point with all delayed applications:

poll([{fd=14, events=POLLIN}], 1, 25000) = 1 ([{fd=14, revents=POLLIN}])
read(14, "1", 16)        = 8
poll([{fd=14, events=POLLIN}], 1, 25000

I’m happy for any hint!

Edit: If somebody is looking for a temporary solution for budgie:

  1. Install menulibre

  2. Open Menu Editor (menulibre) and search for the application which is delayed in startup

  3. Add dbus-launch --exit-with-session APPLICATION to the launching command

  4. Unpin it from Icon Task list

  5. Open app through menu and pin it again

Now the application will start with the dbus-launch command from the start menu and taskbar.

Answered By: Sebastian

I found a possible solution to what seems to be the same problem, which only seems to affect QT (as opposed to GTK) apps and only manifested after a clean Ubuntu Budgie 19.10 install (but not on an in-place upgrade):

  • Edit the ~/.profile file in your /home/$(whoami) director
  • Near the top, add: export QT_STYLE_OVERRIDE=cleanlooks
    (instead of ‘cleanlooks’, you may also be able to use one of cde, motif, plastique, Windows or Fusion (but not ‘gtk2’, which implies it is some dependency problem or other) – the Arch wiki has more information on this environment variable.
  • Log out and log in again, and the QT apps should start super fast again.

You do lose the gtk2 theming of QT apps, though in VLC you can manually set it to use gtk2 theming and it seems to work fine.

Manually setting dbus-launch with QT apps also worked for me (although it leaves orphaned dbus-daemon processes running after each app closes).

Answered By: metastork

I too ran into this problem when upgrading to 20.04. After much reading and testing, I found you receive Two different versions of 20.04 depending on which Upgrade route you choose. If you choose the Internet Release-Upgrade method with 18.04.4 you Don’t have this problem, all Apps open instantly when run as Root or User. If you use the Clean install method with the downloaded image, then you have this problem where Apps open instantly when run as Root but experience a DBUS timeout when run as User.

So it would seem Ubuntu will install two different systems, which one is the intended version? For me, I much prefer the Release-Upgrade method as I find it troubling to have a system that works when running Apps as Root but doesn’t when run as User.

Regards,
Tom

Answered By: TBar

I had a similar problem with GTK-applications and xmonad (and starting X via xinit). I solved it by adding the following line to my .xinitrc:

dbus-update-activation-environment DISPLAY XAUTHORITY
Answered By: student

As mentioned here dbus-launch --exit-with-session APPLICATION leaves orphaned dbus-daemon processes running after each app closes. So i wrote a little script to avoid it:

#!/bin/bash

app="$1"
shift

dbus-launch --exit-with-session "$app" "$@" & pid=$!; sleep 0.5 && export killme=$(pgrep -nx dbus-daemon); export killme2=$(pgrep -f "dbus-launch --exit-with-session $app"); wait $pid && kill $killme $killme2

Save it to your bin PATH, e.g. in ~/bin directory, named fastrun, and run it like:

fastrun APPLICATION
Answered By: superqwerty
Categories: Answers Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.