Realtek RTL8822CE is unable to detect WiFi networks

I bought a HP Stream 11 (Model 11-AK1035NR). I have installed Lubuntu 18.04 on a USB stick to use for it.

I have gotten the WiFi working before on this laptop after playing with it for a few hours. I had to install this again because of a crash on my USB stick. So WiFi is capable on this laptop, but I don’t know exactly how I did it.

I have updated the kernel to Linux Kernel 5.2.2 with no success so far (although it does have the rtw88 which I have read is required). I’ve also looked around this site and saw a fix for RTL8821CE and then compiling a module and that didn’t work either.

I have ran dmesg and this is what I got in terms of the WiFi hardware:

[   14.699016] rtw_pci 0000:01:00.0: Direct firmware load for
rtw88/rtw8822c_fw.bin failed with error -2
[   14.699025] rtw_pci 0000:01:00.0: failed to request firmware
[   14.706008] rtw_pci 0000:01:00.0: failed to load firmware
[   14.708202] rtw_pci 0000:01:00.0: failed to setup chip efuse info
[   14.710395] rtw_pci 0000:01:00.0: failed to setup chip information
[   14.720471] rtw_pci: probe of 0000:01:00.0 failed with error -22

The problem is this:

Direct firmware load for rtw88/rtw8822c_fw.bin failed with error -2

Please install the latest version of linux-firmware which contains it:

wget http://security.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.178.3_all.deb
sudo dpkg -i linux*.deb

Reboot.

Answered By: chili555

If that doesn’t work try this:

wget https://github.com/juanro49/rtl88x2ce-dkms/releases/download/5.7.3_35403_20210523/rtl88x2ce-dkms_35403_amd64.deb
sudo dpkg -i rtl88x2ce-dkms_35403_amd64.deb

Note: worked on HP Pavilion 16 laptop and Ubuntu 16.04 and 18.04

Answered By: Yağız Nalçakan
Unable to locate package rtl8822ce-dkms

However

sudo apt install rtl8821ce-dkms

Worked perfectly for Ubuntu 20.04.6 LTS

Answered By: ukkid35
Categories: Answers Tags: , , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.